pike.git / src / threads.h

version» Context lines:

pike.git/src/threads.h:1:   /* -  * $Id: threads.h,v 1.79 2000/08/06 08:44:14 neotron Exp $ +  * $Id: threads.h,v 1.80 2000/08/06 14:39:33 grubba Exp $    */   #ifndef THREADS_H   #define THREADS_H      #include "machine.h"   #include "interpret.h"   #include "object.h"   #include "error.h"      /* Needed for the sigset_t typedef, which is needed for
pike.git/src/threads.h:34: Inside #if defined(PIKE_THREADS)
  #define UNIX_THREADS   #include <thread.h>   #undef HAVE_PTHREAD_H   #undef HAVE_THREAD_H   #endif   #endif /* _UNIX_THREADS */      #ifdef _MIT_POSIX_THREADS   #define POSIX_THREADS   #include <pthread.h> +  + /* AIX is *STUPID* - Hubbe */ + #undef func_data +    #undef HAVE_PTHREAD_H   #endif /* _MIT_POSIX_THREADS */      #ifdef _SGI_SPROC_THREADS   /* Not supported yet */   #undef SGI_SPROC_THREADS   #undef HAVE_SPROC   #endif /* _SGI_SPROC_THREADS */